Friday, August 27, 2010

Java compiler level does not match the version of the installed Java project facet.

When porting the Eclipse workspace to another computer or another java version there may happen an error like this:

"Java compiler level does not match the version of the installed Java project facet. Unknown Faceted Project Problem (Java Version Mismatch)"

Different solutions can be searched or applied but I would recommend you to check firstly if the JDK is properly installed and after checkcing this you need to right-click to the error and chose Quick Fix. After that there are shown 2 optional choices which one of them is to use your current JDK version. By choosing that you fix your workspace problem.

1 comment:

  1. This comment has been removed by a blog administrator.

    ReplyDelete